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Introduction
Terra License Server and Terra License Manager provide the capability for the customer to 
maintain a pool of licenses from which to borrow licenses for individual workstations. This gives 
flexibility in moving TerraScan, TerraModeler or other Terra application licenses from one 
computer to another.

Terra License Server runs on a machine acting as a server. This server computer stores a 
collection of licenses. Workstation users can request a specific application license for a given 
number of days. The server application will grant such a license if the pool has an available license 
for that application. The workstation computer can return the license to the pool at any time. If 
never returned, the license will automatically become available in the pool once the validity period 
runs out.

Terra License Service is a service version of the license server. It can run in the background 
without a user interface. When Terra License Service is installed, Terra License Server will act 
merely as a user interface for viewing the status of the license pool being managed by the service 
and for changing settings.

Terra License Manager is typically installed on several computers where customer wants to run 
TerraScan, TerraModeler or some other Terra application(s). Terra License Manager 
communicates with Terra License Server thru a Windows network whenever requesting a 
license or returning a license.

One of the workstation computers can act as the server machine at the same time.

The pool license system provides the following benefits:

• You can freely decide which computers have licenses to run Terra applications.
• You can easily move licenses from one computer to another.
• When you start a long batch process, you only need to leave the license for that particular 

application on the working computer. You can return other licenses to the server and move 
those to another workstation.

• You can borrow a license to be used on a notebook computer for a given number of days. The 
notebook needs to be connected to the network only at the time of requesting the license. If 
the notebook never returns to the main office, the borrowed license becomes available again 
when the validity period ends.
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Hardware and software requirements
Terra License Server and Terra License Manager are Windows based applications. Both 
applications work with different variations of Windows 2000, Windows XP or Windows Vista.

The individual workstation computers must be on the same network with the computer acting as 
the server. The server computer must appear in Widnows list of network computers.

Running setup

� To install Terra License Server or Terra License Manager:

1. Start setup.exe in the installation package.

This opens the Terra Setup dialog:

2. Select Terra License Manager, Terra License Server and/or Terra License Service to 
install.

3. The installation program prompts you to enter the location where to install the software. 
The default path is C:\TERRA. You can set this to another location if you prefer.  The 
specified directory will be automatically created, if it does not exist.

4. Click OK.

When the installation is finished, a message is displayed. The installation creates shortcuts 
in the Start menu to for running the installed applications.
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You should carefully consider to which computer to install Terra License Server. The pool of 
licenses that you get from Terrasolid will only work on that specific computer. You should 
therefore install Terra License Server on a computer which you plan to use for a long time.

� To configure Terra License Server, you should perform the following steps:

1. Enter server settings.

2. Enter manager settings.

3. Test that Terra License Server and Terra License Manager can communicate with each 
other on your network.

4. Send server information to Terrasolid for pool licenses linked to your server machine.

5. Copy pool licenses to the same folder where license_server.exe is.

This chapter explains each of the steps in detail.

Entering server settings

Server settings specify an access code for the license pool and the maximum duration for which 
licenses will be granted.

� To enter server settings:

1. Run Terra License Server.

2. Select Settings command from File pulldown menu.

This opens the Settings dialog:

3. Specify an access code which you have decided. All client computers must use a matching 
access code.

4. Enter the maximum duration for which licenses can be generated. A short duration requires 
users to renew licenses more frequently but it is safer -- if a computer with borrowed 
licenses breaks down, the licenses will become available as soon as the validity period ends.

5. Click OK.
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Entering manager settings

Manager settings specify an access code for the license pool and the network name of the server 
computer.

� To enter server settings:

1. Run Terra License Manager.

2. Select Settings command from File pulldown menu.

This opens the Settings dialog:

3. Enter name of server computer. You can click on >> button to browse network computers.

4. Specify an access code matching the access code on the server.

5. Click OK.

Testing network communication

To test network communication, you need to have Terra License Server installed on one 
computer and Terra License Manager on another computer. You should also have entered the 
settings for both applications as explained above.

� To test network communication:

1. Start Terra License Server on the server machine. Check Event log for version number 
(008, 009, ...) that it is going to serve:

2. Start Terra License Manager on another computer.

3. Select one of the applications in the manager list for which you do not have a valid license 
on that computer.

4. Select Get from server command from License pulldown menu.

5. This opens the Get from server dialog:

6. Select version number in the Version field to match the Event log on the server.
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7. Click OK.

The selected application in the list will show ‘No reply from server’ message for a few 
seconds if manager can not establish communication with the server. Check all the steps 
above to make sure everything is set up correctly.

The selected application in the list will show ‘No free license’ or some other message if the 
communication with the server works.

Sending server information

You need to send server name and identification number to Terrasolid before receiving pool 
licenses. The generated licenses can only be distributed by Terra License Server running on the 
same server machine.

� To send server machine details:

1. Run Terra License Server.

2. Select Server information command from File pulldown menu.

This opens the Server information dialog:

You can copy the computer name and computer identifiier to paste into an E-mail that you 
send to Terrasolid or you can click on Open web to enter the details to a web page.

If you are eligible for licenses, you will receive a number of license files which you should 
copy to the same folder where license_server.exe is. Default location is c:\terra\pool008 for 
version 008 licenses, c:\terra\pool009 for version 009 licenses and so on.
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Terra License Server needs to be running whenever users want to request or return licenses. It is 
probably easiest to leave the program always running on the server computer.

Alternatively, you can install Terra License Service which will run automatically. You can then 
run Terra License Server when you want to view the status of the license pool or change server 
settings.

Terra License Server shows the current state of the license pool and logs every request and return 
event.

Licensed applications list shows a list of applications for which the program finds valid licenses 
in the same folder where the executable is.

Licenses window shows the status of each license for the application selected in Licensed 
applications list.

Event log shows all the events since the program was last started. The program keeps adding 
messages to license_server_log.txt text file which stores all events since the server was installed.
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Terra License Manager executable license_manager.exe has to reside in the same folder as the 
licenses for Terra applications. The default location is c:\terra\license.

Hiding unneeded applications
When you start Terra License Manager, it displays a window showing a number of applications:

The list may show applications that you never use and you may want to hide those.

� To hide unneeded applications:

1. Select rows of applications to hide.

2. Select Hide selected applications command from View pulldown menu.

This hides the applications selected. If you need to restore the visibility of applications, you 
should select Show all applications command from View pulldown menu.

Requesting licenses
The most common task with Terra License Manager is to request new licenses from the server.

� To request licenses:

1. Select rows of applications you want to request a license for.

2. Select Get from server command from License pulldown menu.

This opens the Get From Server dialog:

3. Select application version in the Version field.

4. Enter desired Duration or enter the date thru which the license should be valid.

5. Click OK.

This sends a request to the server. If a license is granted, you will see the new validity period 
in application list. Settings on the server may limit the duration of the generated license.



Page 10
5 Running Terra License Manager

� To change the duration of a license, you simply request it again with a new duration. You can 
request for a longer or a shorter duration. For example, if you leave the computer processing a long 
task with TerraMatch, you may use Terra License Manager to request a longer license while 
TerraMatch is busy working.

Returning licenses
You can return a license to the server at any time before it expires. This will make the license 
available to be granted to another workstation.

� To return licenses:

1. Select rows of applications you want to request a license for.

2. Select Return to server command from License pulldown menu.

This sends a return message to the server. The licenses disappear from your computer only 
if the server acknowledges receiving the licenses.
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Can I purchase new licenses and add to the pool?

Yes, please. Simply place new license files that you receive into the same folder where 
license_server.exe is. You should close Terra License Server and restart it. If you are running 
Terra License Service, you should pause and continue the service from Control Panel.

Can I move licenses to another server?

No. Licenses are tied to the one specific server machine.

How do we move from one major version to another?

You should install a new version of Terra License Server (and Terra License Service if you 
running it as a servide). The setup will create a dedicated new folder such as c:\terra\pool014 for 
the new version. When you receive new licenses from Terrasolid for version 014, copy those to 
\pool014 folder.

Can we use version 012.xxx and version 013.xxx applications at the same time?

Yes, for a few months. You can run two instances of license_server.exe or license service at the 
same. You simply need to have two separate folders such as c:\terra\pool012 and c:\terra\pool013. 
Each folder should have its own copy of license_server.exe and its own collection of licenses.

User can request version 012 license of TerraScan and version 013 license of TerraModeler. 

This concurrent use can only last for a few months. Version 012 pool licenses are only valid until 
31.03.2013. Version 013 pool licenses will be valid until 31.03.2014 and so on.

I have accidentally deleted a license file on the workstation. How do I proceed?

This has left you in a situation where the server sees that license as being reserved even when your 
workstation does not have a working license. To proceed you simply request a license for that 
application using Terra License Manager on that workstation. License server will grant the same 
license which was already reserved for your workstation.


